Jul032013

Instalar la última versión de Iceweasel en Debian Wheezy.

Iceweasel Linux gnu blog

Tener la ultima versión de Iceweasel en Debian Wheezy stable, es muy sencillo.

Lo primero es añadir los repositorios adecuados, y para ello desde la Terminal, empecemos por abrir el editor nano como root.

# nano /etc/apt/sources.list

Añadimos los “Backports” a sources.list.

deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free
deb-src http://ftp.debian.org/debian/ wheezy-backports main contrib non-free

deb http://mozilla.debian.net/ wheezy-backports iceweasel-release
deb-src http://mozilla.debian.net/ wheezy-backports iceweasel-release

Guardamos los cambios (Ctrl+O Enter Ctrl+X).

Ahora añadimos la llave pública del repositorio Mozilla backports a apt.

# wget -O- -q http://mozilla.debian.net/archive.asc | apt-key add –

Y actualizamos la base de datos.

# apt-get update

Para finalizar, procedemos a instalar la última versión de Icewasel y su paquete de idiomas.
En mi caso: l10n-es-es.

# apt-get install -t wheezy-backports iceweasel iceweasel-l10n-es-es

Te puede interesar: Repositorios Debian Wheezy stable.

Política de comentarios

Dada la importancia de los comentarios como espacio de participación, te pedimos por favor que leas detenidamente y cumplas con las siguientes normas de participación.

26 respuestas para “Instalar la última versión de Iceweasel en Debian Wheezy.

Instalar la última versión de Ice...

[…] Tener la ultima versión de Iceweasel en Debian Wheezy stable, es muy sencillo. Lo primero es añadir los repositorios adecuados, y para ello desde la T  […]


Manuel Solis-Zavala

Muchas gracias, funcionó de maravilla! Ahora puedo integrar casi cualquier Add-on a Iceweasel


José Miguel

Me alegro “Manuel”.

Muchas gracias por comentar.

Saludos.


Carlos

# apt-get install -t wheezy-backports iceweasel iceweasel-l10n-es-es
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Leyendo la información de estado… Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
iceweasel : Depende: libcairo2 (>= 1.10.2-1.1~) pero 1.8.10-6 va a ser instalado
Depende: libfontconfig1 (>= 2.9.0) pero 2.8.0-2.1 va a ser instalado
Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) pero no es instalable
Depende: xulrunner-23.0 (>= 23.0-1~bpo70+1) pero no va a instalarse
Depende: libsqlite3-0 (>= 3.7.12-1~) pero 3.7.3-1 va a ser instalado
E: Paquetes rotos


Elías R.M.

Hola Carlos, soy Elías, segundo administrador de la web.

Antes de nada, seria recomendable que ejecutaras apt-get install -f como super ususario para que se corrijan todos los problemas derivados de paquetes rotos.

Tras eso, para poder intentar diagnosticar tu problema concreto, puedes ejecutar cat /etc/apt/sources.list y responder a este comentario con el resultado de dicho comando.

Muchas gracias por tu comentario.

Saludos


Ghermain

¿Sabes como se puede instalar en Kubuntu 13.10 de 64 bits?
He intentado de todas las formas que aparecen por Google y con ninguna he tenido resultado.


José Miguel

A ver… En principio no entiendo la necesidad de instalar Iceweasel disponiendo de Firefox.

No tengo Kubuntu instalado, lo cual no me permite experimentar, así no puedo ayudarte adecuadamente.

Aunque GDebi podría ser una solución, lo más seguro es que tengas problemas de dependencias.

Mi recomendación es de uses Firefox o Debian. je je…

Saludos.


Ghermain

Gracias, lo que sucede es que lo había probado en Debian y me gustó mucho y ahora lo quiero para Kubuntu y tenerlo junto a Firefox, Qupzilla y Seamonkey que son los que uso.


José Miguel

Prácticamente no hay diferencias ente Iceweasel y Firefox.
Yo uso Chromium…

Saludos.


Yael

Hola. El tutorial me funcionó, actualizó a la versión 27. El icono de iceweasel sigue igual sin embargo al iniciar la aplicación ya no es iceweasel sino nightly, tengo entendido que iceweasel es el único con licencia GPL.
Por qué ahora es nightly? La licencia ha cambiado?
Gracias


José Miguel

Nightly es la la rama de desarrollo inestable de Mozilla, donde se prueban los últimos cambios. Enfocada más bien a desarrolladores.

Tener lo último tiene sus riesgos, en mi caso no he tenido problemas importantes, pero no es una rama recomendable si es tu navegador por defecto.

Después le sigue la rama Aurora, mucho más estable, pero también en desarrollo.

Saludos.


arturo

felicito por la descripcion clara detallada de los procedimientos para las intalaciones , saludos
recien uso debian jessie con Iceweasel y me gusta


José Miguel

Muchas gracias Arturo.

Saludos.


Fernando

Funciono barbaro, muy buena descripcion de los pasos a seguir, ahora mi máquina con MININO tiene el IceWeasel funcionando..

Gracias


José Miguel

Gracias a ti por comentar.

Saludos.


Actualiza Iceweasel | linuxsoporte

[…] informacion obtenida de http://linuxgnublog.org/instalar-la-ultima-version-de-iceweasel-en-debian-wheezy […]


Carlos

# apt-get install -t wheezy-backports iceweasel iceweasel-l10n-es-es
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Leyendo la información de estado… Hecho
iceweasel-l10n-es-es ya está en su versión más reciente.
Paquetes sugeridos:
ttf-mathematica4.1 xprint mozplugger
Se instalarán los siguientes paquetes NUEVOS:
iceweasel
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/1100 kB de archivos.
Se utilizarán 4071 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]?
(Leyendo la base de datos … 230077 ficheros o directorios instalados actualmente.)
Desempaquetando iceweasel (de …/iceweasel_3.5.16-20_i386.deb) …
dpkg-divert: No se pueden desviar directorios

Utilice –help para obtener ayuda de la consulta de paquetes.
dpkg: error al procesar /var/cache/apt/archives/iceweasel_3.5.16-20_i386.deb (–unpack):
el subproceso script pre-installation nuevo devolvió el código de salida de error 2
configured to not write apport reports
Procesando disparadores para menu …
Se encontraron errores al procesar:
/var/cache/apt/archives/iceweasel_3.5.16-20_i386.deb
N: Ignoring file ‘wuala.list.save’ in directory ‘/etc/apt/sources.list.d/’ as it has an invalid filename extension
N: Ignoring file ‘upp-nightly.list.save’ in directory ‘/etc/apt/sources.list.d/’ as it has an invalid filename extension
E: Sub-process /usr/bin/dpkg returned an error code (1)


Victorx66

Hola si funciona; tengo una pregunta porque se añaden 2 repositorios si solo se toma la instalación del repositorio backports? .Gracias!


José Miguel

Interesante pregunta, y me tocó a mi. 😉

La razón es muy sencilla: Si no añades los repositorios de Mozilla, no dispondrías de la última versión.

En mi caso y, en estos momentos, en vez de la 34.0 tendría la 31.3.0.

Saludos.


victorx66

Entonces lo que imaginaba … decir que el backports saca lo más nuevo (busca la última version) del repositorio Moxilla.
Thanks a lot!


Andrés

Muchas gracias. Me ha funcionado perfectamente.


Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *