Abr072016

Como instalar la última versión de Firefox en Debian Jessie

Después de la reconciliación de Debian con Mozilla y el adiós definitivo a Iceweasel, instalar y disponer de la última versión de Firefox en Debian Jessie stable, es muy sencillo. Pero antes de proceder, si aun tienes Iceweasel, debes desinstalarlo completamente.

Repositorios

Lo primero es añadir los repositorios adecuados, y para ello desde la Terminal, empecemos por abrir el editor nano como root.

# nano /etc/apt/sources.list

Lo primero es comprobar si disponemos los “Backports”.

# Backports
deb http://ftp.fr.debian.org/debian jessie-backports main contrib non-free
deb-src http://ftp.fr.debian.org/debian jessie-backports main contrib non-free

Añadimos los repositorios de Mozilla

# Mozilla
deb http://mozilla.debian.net/ jessie-backports firefox-release
deb-src http://mozilla.debian.net/ jessie-backports firefox-release

Guardamos los cambios (Ctrl+O Enter Ctrl+X).

Añadimos la llave pública.

# apt-get install pkg-mozilla-archive-keyring debian-keyring

Y actualizamos la base de datos.

# apt-get update

Instalación

Procedemos a instalar la última versión de Firefox y su paquete de idiomas. En mi caso: firefox-l10n-es-es.

# apt-get install -t jessie-backports firefox firefox-l10n-es-es

Para finalizar y con el objetivo de eliminar paquetes obsoletos:

# apt-get upgrade

Y eso es todo compañeros, mi primer Firefox en Debian. 😉

Linux gnu blog Firefox

Política de comentarios

Dada la importancia de los comentarios como espacio de participación, te pedimos por favor que leas detenidamente y cumplas con las siguientes normas de participación.

20 respuestas para “Como instalar la última versión de Firefox en Debian Jessie

Zicoxy3

Acabo de iniciarme con Debian y hecho de menos Firefox… aunque sea absurdo, no ver el icono del panda rojo parece que no tenga navegador.
gracias


José Miguel

Pues la situación ha cambiado, afortunadamente, para todos.

Saludos.


Juan

Excelente tutorial, anteriormente instale y al actualizar tenia problemas, quedo muy bien.
Gracias


José Miguel

Gracias a ti por comentar, así sabemos que todo funciona correctamente.

Saludos.


petoniano

apt-get install -t jessie-backports firefox-esr-l10n-es-es

Es lo que me ha funcionado a día de hoy, muchas gracias por el tutorial


José Miguel

Me alegro, de eso se trata.

Saludos.


Maurizio De Sanctis

Hola José Miguel,
Tengo que remplazar iceweasel con firefox en el portatil y en el desktop.

Segun lo que entiendo es necesario primero desinstalar iceweasel.
Cuáles son los paquetes de desinstalar y cómo hago?

En el portatil tengo Apper. Ayuda en algo?

Gracias

Maurizio


José Miguel

Antes de nada, desinstala Iceweasel. Después, sigue las instrucciones del post. Si tienes repositorios de Iceweasel, sustitúyelos por los indicados en el post. Si te surge alguna duda o inconveniente, nos lo comentas.

Saludos.


Maurizio

Hola José Miguel, acabo de instalar firefox en el portátil y parece que todo está bien.
Te lo agradezco mucho por el excelente tutorial y por las sugerencias.

Ahora me gustaría instalar firefox en el computador de escritorio que tiene el sistema (más antiguo):
[Debian GNU/Linux 6.0.5 _Squeeze_ – Official amd64 kde-CD Binary-1 20120512-14:33]/ squeeze main

¿ Es posible ? ¿Qué tengo que hacer?

Gracias
Maurizio


José Miguel

Pues muy fácil; puedes utilizar este mismo tutorial, simplemente sustituyendo jessie por squeeze.

Saludos.


luis

que tal.
intente instalar firefox siguiendo los pasos en esta pagina en la ultima version estable de crunchbang que incluye debian jessie.
todo esta bien hasta el momento de la instalacion en donde al final del proceso se detiene y me da los siguientes errores en la terminal
The following packages have unmet dependencies:
firefox : Depends: libc6 (>= 2.17) but 2.13-38+deb7u11 is to be installed
Depends: libffi6 (>= 3.0.4) but it is not installable
Depends: libfontconfig1 (>= 2.11) but 2.9.0-7.1 is to be installed
Depends: libhunspell-1.3-0 (>= 1.3.3) but 1.3.2-4 is to be installed
Depends: libpango-1.0-0 (>= 1.14.0) but it is not installable
Depends: libstdc++6 (>= 4.9) but 4.7.2-5 is to be installed
E: Unable to correct problems, you have held broken packages.

como puedo corregir esos errores o que paqueteria deveria estar instalando para mi sistema operativo.
Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2 x86_64 GNU/Linux


José Miguel

No puedo comprobar lo que te voy a decir, pues no uso Crunchbang. Las indicaciones que se dan en el post son para Debian, pero por lo que veo, el problema podría tener relación con los backports. Pero si has seguido las indicaciones y has añadido los backports de jessie, en principio no deberían surgir inconvenientes.

Saludos.


mauro fragoso

si ya tengo firefox esr 45.5 y quiero actualizar a 49.1 o 50 beta me sirve este metodo ???


José Miguel

Menos para la beta, tengas la que tengas actualizará a la última versión.

Saludos.


Sergio Capacho

Me funciono muy bien, es más noto la navegación es más rápida. Gracias por su aporte


José Miguel

Gracias por comentar, es bueno saber que funciona.

Saludos.


Juan Pablo Calles

Hola, José Miguel. Venturoso 2017!
Tengo una raspberry pi 2 B+.
Mi duda: este post sirve para SO Raspbian de esta fecha?
Muchas gracias!


Elías R.M.

Hola Juan Pablo, Feliz año!

Las instrucciones de este artículo no valen para Raspberry PI, en su lugar, prueba a añadir este repositorios PPA, puede que te funcione:

deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu trusty main

Luego ejecuta en la terminal:

# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7EBC211F
# apt-get update
# apt-get install firefox

No estoy seguro de cual es la versión de Ubuntu más compatible con Debian jessie, si te da problemas de dependencias, prueba a cambiar trusty por vivid.

Ya nos cuentas si funciona 😉

Saludos


Deja un comentario

Tu dirección de correo electrónico no será publicada.